首页 > 知识库 > 正文

loopback是什么技术 loopback怎么样

loopback指本地环回接口(或地址),亦称回送地址()。此类接口是应用最为广泛的一种虚接口,几乎在每台路由器上都会使用。基本信息 中文名:loopback 英文名:loopback address 其他外文名:loopback 别称:回送地址 类型:计算机术语 使 用:接口地址作为OSPF采 用:127.0.0.1作为本地环回地址

环回地址

在Windows系统中,采用127.0.0.1作为本地环回地址。

BGP Update-Source

BGP Update-Source

因为Loopback口只要Router还健在,则它就会一直保持Active,这样,只要BGP的Peer的Loopback口之间满足路由可达,就可以建立BGP 会话,总之BGP中使用loopback口可以提高网络的健壮性。

neighbor 215.17.1.35 update-source loopback

Router ID

使用该接口地址作为OSPF 、BGP 的Router-ID,作为此路由器的唯一标识,并要求在整个自治系统内唯一,在Ipv6中的BGP/OSPF的Router-ID仍然是32位的IP地址。在OSPF中的路由器优先级是在接口下手动设置的,接着才是比较OSPF的Router-ID(Router-ID的选举在这里就不多说了,PS:一台路由器启动OSPF路由协议后,将选取物理接口的最大IP地址作为其RouterID,但是如果配置Loopback接口,则从Loopback中选取IP地址最大者为RouterID。另外一旦选取RouterID,OSPF为了保证稳定性,不会轻易更改,除非作为RouterID的IP地址被删除或者OSPF被重新启动),在OSPF和BGP中的Router-ID都是可以手动在路由配置模式下设置的。

OSPF: Router-ID *.*.*.*

BGP:BGP Router-ID *.*.*.*

IP Unnumbered Interfaces

无编号地址可以借用强壮的loopback口地址,来节约网络IP地址的分配。

例子:

interface loopback 0

ip address 215.17.3.1 255.255.255.255

!

interface Serial 5/0

bandwidth 128

ip unnumbered loopback

0Exception Dumps by FTP

当Router 宕机,系统内存中的文件还保留着一份软件内核的备份,CISCO路由器可以被配置为向一台FTP服务器进行内核导出,作为路由器诊断和调试处理过程的一部分,可是,这种内核导出功能必须导向一台没有运行公共FTP服务器软件的系统,而是一台通过ACLS过滤(TCP地址欺骗)被重点保护的只允许路由器访问的FTP服务器。如果Loopback口地址作为Router的源地址,并且是相应地址块的一部分,ACLS的过滤功能很容易配置。

Sample IOS configuration:

ip ftp source-interface Loopback0

ip ftp username cisco

ip ftp password 7 045802150C2E

exception protocol ftp

exception dump 169.223.32.1

TFTP-SERVER Access

对于TFTP的安全意味着应该经常对IP源地址进行安全方面的配置,CISCO IOS软件允许TFTP服务器被配置为使用特殊的IP接口地址,基于Router的固定IP地址,将运行TFTP服务器配置固定的ACLS.

ip tftp source-interface

Loopback0 SNMP-SERVER Access

路由器的Loopback口一样可以被用来对访问安全进行控制,如果从一个路由器送出的SNMP网管数据起源于Loopback口,则很容易在网络管理中心对SNMP服务器进行保护

Sample IOS configuration:

access-list 98 permit 215.17.34.1

access-list 98 permit 215.17.1.1

access-list 98 deny any

!

snmp-server community 5nmc02m RO 98

snmp-server trap-source Loopback0

snmp-server trap-authentication

snmp-server host 215.17.34.1 5nmc02m

snmp-server host 215.17.1.1 5nmc02m.Wednesday, June 06, 2001

TACACS/RADIUS-Server Source Interface

当采用TACACS/RADIUS协议,无论是用户管理性的接入Router还是对拨号用户进行认证,Router都是被配置为将Loopback口作为Router发送TACACS/RADIUS数据包的源地址,提高安全性。

TACACS

aaa new-model

aaa authentication login default tacacs+ enable

aaa authentication enable default tacacs+ enable

aaa accounting execstart-stoptacacs+

!

ip tacacs source-interface Loopback0

tacacs-server host 215.17.1.2

tacacs-server host 215.17.34.10

tacacs-server key CKr3t#

!

RADIUS

radius-server host 215.17.1.2 auth-port 1645 acct-port 1646

radius-server host 215.17.34.10 auth-port 1645 acct-port 1646

ip radius source-interface Loopback0

!

NetFlow Flow-Export

从一个路由器向NetFlow采集器传送流量数据,以实现流量分析和计费目的,将路由器的Router的Loopback地址作为路由器所有输出流量统计数据包的源地址,可以在服务器或者是服务器外围提供更精确,成本更低的过滤配置。

ip flow-export destination 215.17.13.1 9996

ip flow-export source Loopback0

ip flow-export version 5 origin-as

!

interface Fddi0/0/0

description FDDI link to IXP

ip address 215.18.1.10 255.255.255.0

ip route-cache flow

ip route-cache distributed

no keepalive

!

FDDDI 0/0/0 接口被配置成为进行流量采集。路由器被配置为输出第五版本类型的流量信息到IP地址为215.17.13.1的主机上,采用UDP协议,端口号9996,统计数据包的源地址采用Router的Loopback地址。

NTP Source Interface

NTP用来保证一个网络内所有Rdouter的时钟同步,确保误差在几毫秒之内,如果在NTP的Speaker之间采用Loopback地址作为路由器的源地址,会使得地址过滤和认证在某种程度上容易维护和实现,许多ISP希望他们的客户只与ISP自己的而不是世界上其他地方的时间服务器同步。

clock timezone SST 8

!

access-list 5 permit 192.36.143.150

access-list 5 permit 169.223.50.14

!.Cisco ISP Essentials

39

ntp authentication-key 1234 md5 104D000A0618 7

ntp authenticate

ntp trusted-key 1234

ntp source Loopback0

ntp access-group peer 5

ntp update-calendar

ntp peer 192.36.143.150

ntp peer 169.223.50.14

!

SYSLOG Source Interface

系统日志服务器同样也需要在ISP骨干网络中被妥善保护。许多ISP只希望采集他们自己的而不是外面网络发送来的昔日日志信息。对系统日志服务器的DDOS攻击并不是不知道,如果系统信息数据包的源地址来自于被很好规划了的地址空间,例如,采用路由器的Loopback口地址,对系统日志服务器的安全配置同样会更容易。

A configuration example:

logging buffered 16384

logging trap debugging

logging source-interface Loopback0

logging facility local7

logging 169.223.32.1

!

Telnet to the Router

远程路由器才用Loopback口做远程接入的目标接口,这个一方面提高网络的健壮性,另一方面,如果在DNS服务器做了Router的DNS映射条目,则可以在世界上任何路由可达的地方Telnet到这台Router,ISP会不断扩展,增加新的设备

由于telnet 命令使用TCP 报文,会存在如下情况:路由器的某一个接口由于故障down 掉了,但是其他的接口却仍旧可以telnet ,也就是说,到达这台路由器的TCP 连接依旧存在。所以选择的telnet 地址必须是永远也不会down 掉的,而虚接口恰好满足此类要求。由于此类接口没有与对端互联互通的需求,所以为了节约地址资源,loopback 接口的地址通常指定为32 位掩码。

DNS前向和反向转发区域文件的例子:

; net.galaxy zone file

net.galaxy. IN SOA ns.net.galaxy. hostmaster.net.galaxy. (

1998072901 ; version == date(YYYYMMDD)+serial

10800 ; Refresh (3 hours)

900 ; Retry (15 minutes)

172800 ; Expire (48 hours)

43200 ) ; Mimimum (12 hours)

IN NS ns0.net.galaxy.

IN NS ns1.net.galaxy.

IN MX 10 mail0.net.galaxy.

IN MX 20 mail1.net.galaxy.

;

localhost IN A127.0.0.1

gateway1 IN A 215.17.1.1

gateway2 IN A 215.17.1.2

gateway3 IN A 215.17.1.3

;

;etc etc

; 1.17.215.in-addr.arpa zone file

;

1.17.215.in-addr.arpa. IN SOA ns.net.galaxy. hostmaster.net.galaxy. (

1998072901 ; version == date(YYYYMMDD)+serial

10800 ; Refresh (3 hours)

900 ; Retry (15 minutes)

172800 ; Expire (48 hours)

43200 ) ; Mimimum (12 hours)

IN NS ns0.net.galaxy.

IN NS ns1.net.galaxy.

1 IN PTR gateway1.net.galaxy.

2 IN PTR gateway2.net.galaxy..Wednesday, June 06, 2001

3 IN PTR gateway3.net.galaxy.

;

;etc etc

On the router, set the telnet source to the loopback interface:

ip telnet source-interface Loopback0

RCMD to the router

RCMD 要求网络管理员拥有UNIX的rlogin/rsh客户端来访问路由器。某些ISP采用RCMD来捕获接口统计信息,上载或下载路由器配置文件,或者获取Router路由选择表的简易信息,Router可以被配置采用Loopback地址作为源地址,使得路由器发送的所有数据包的源地址都采用Loopback地址来建立RCMD连接:

ip rcmd source-interface Loopback0

含义

路由器管理地址

1.系统管理员完成网络规划之后,为了方便管理,会为每一台路由器创建一个loopback 接口,并在该接口上单独指定一个IP 地址作为管理地址,管理员会使用该地址对路由器远程登录(telnet ),该地址实际上起到了类似设备名称一类的功能。

但是通常每台路由器上存在众多接口和地址,为何不从当中随便挑选一个呢?

原因如下:由于telnet 命令使用TCP报文,会存在如下情况:路由器的某一个接口由于故障down 掉了,但是其他的接口却仍旧可以telnet ,也就是说,到达这台路由器的TCP 连接依旧存在。所以选择的telnet 地址必须是永远也不会down 掉的,而虚接口恰好满足此类要求。由于此类接口没有与对端互联互通的需求,所以为了节约地址资源,loopback 接口的地址通常指定为32 位掩码。

动态路由协议

使用该接口地址作为动态路由协议OSPF 、BGP 的router id 动态路由协议OSPF 、BGP 在运行过程中需要为该协议指定一个Router id ,作为此路由器的唯一标识,并要求在整个自治系统内唯一。由于router id 是一个32 位的无符号整数,这一点与IP 地址十分相像。而且IP 地址是不会出现重复现象的,所以通常将路由器的router id 指定为与该设备上的某个接口的地址相同。由于loopback 接口的IP 地址通常被视为路由器的标识,所以也就成了router id 的最佳选择。

BGP源地址

使用该接口地址作为BGP 建立TCP 连接的源地址

在BGP 协议中,两个运行BGP 的路由器之间建立邻居关系是通过TCP 建立连接完成的。

在配置邻居时通常指定loopback 接口为建立TCP 连接的源地址(通常只用于IBGP ,原因同2.1 ,都是为了增强TCP 连接的健壮性)

配置命令如下:

router id 61.235.66.1

interface loopback 0

ip address 61.235.66.1 255.255.255.255

router bgp 100

neighbor 61.235.66.7 remote-as 200

neighbor 61.235.66.7 update-source LoopBack0

声明:本网内容收集自互联网,旨在传播知识仅供参考,不代表本网赞同其观点,文字及图片版权归原网站所有。

更多精彩内容推荐:

补肾最有效的方法是什么?

补肾最有效的方法是什么?健康苦行僧,开讲啦!肾脏是身体的本钱,生命之源。如果肾脏出现问题,就会引起身体的很多问题,会让人早衰,日常生活也会受到非常严重的影响。那么日常生活中我们怎么做才能帮助补肾壮阳,合理养肾呢?一:养肾的食物补肾养肾的食物有很多,比如韭菜,秋葵,甲鱼,鳝鱼,山药...

贵阳白云区今后的发展将会如何?

贵阳的白云区就像一句不恰当的俗话"媳妇熬成婆”的感觉,几个区当中小河被花溪并了,乌当区虽一直在贵阳市的核心区域中,但总是不温不火,之前的白云区,花溪区,小河区因交通问题,距老城中心都比较远,所以都有进城去的说法。但白云区在几个区当中发展可以说是最差的一个。随着金阳新区的成立,市政...

你身边闷声发大财的人都是做什么生意的?

身边一个人,做建材石膏板,一张板也就一两块钱的利润,四年时间,几百万的别墅,门面买了一排,跟着干活的亲戚都发财了...

山东为什么不发展滨州?

我是冰哥聊史论古今,我来回答。我是山东人,老家不是滨州的,但是去滨州出过几次差,和滨州的朋友也聊过当地的经济,所以对这个问题算是有点发言权。以下是我梳理的关于滨州未发展的一些原因,对其他地区可能也有借鉴意义。先通过经济数据来了解滨州整体的经济形势。2018年的山东省GDP排名中,...

每天坚持喝枸杞水,坚持喝一个月会有什么好处?

感谢邀请。枸杞对于大部分朋友来说都是个宝,感觉离了枸杞这身体好像就要衰弱下去,每天吃枸杞像是一种维持健康身体的必做事情。大家更喜爱的方式是用枸杞泡水喝,枸杞直接吃有些硬朗塞牙,对于牙口不好的朋友来说更难咀嚼,枸杞泡水能够将枸杞中的清甜味道泡到水里,避免了咀嚼,不过泡水喝的枸杞建议...

南阳南部规划多远?

感谢邀请,从目前南阳的规划来看,南阳发展还是非常有侧重点的,向南也是规划到宁西铁路和二广高速交叉点一带。从2017年到2020年的用地规划来看,南阳向南部重点发展的是白河到沪陕高速、二广高速之间的区域,这片区域也将对村庄进行安置,进行产业化发展,只有一小部分在沪陕高速以南,再向南...

“郑许一体化”会给许昌带来怎样的发展前景?

感谢邀请,郑许一体化在2018年已经作为一个重点项目来推进建设,它也是未来郑州大都市区的一部分,将来会使许昌与郑州靠的更近,势必让许昌经济发展的更好,这几年许昌也有很多表现来印证了这个政策下带来的变化。第一、许昌产业更加集聚,城市发展速度加快。许昌在向北推进中首先是撤许昌县划为建...

“三一重工”为什么离开湖南?

是因为中联重科排挤吗?...

长期喝红豆薏米粥会怎样?

长期喝红豆薏米粥会怎么样?健康苦行僧,开讲啦!要问吃什么祛湿,可能很多人都会回答道:红豆薏米粥,是呀,红豆薏米粥可以说是祛湿的经典搭配了,二者都有利水祛湿,健脾养胃的功效,搭配食用,能够很好地帮助祛湿,那么长期食用红豆薏米粥真的会祛湿吗,怎么感觉湿气加重了一些。长期食用红豆薏米粥...

“寺”和“庙”有什么区别?

现在国内有许多的关于佛教的新闻报道,从这些报道中,我们经常可以看到记者们都将佛教的寺院统称为“寺庙”。即便有时候跟朋友们聊天的时候,也会时常听见他们说:“我什么什么时候到哪个庙里却烧香拜佛了。”即便是在新闻报道里,记者们也经常会将佛教的寺院给写为“寺庙”。其实我们大家都知道,他们...

老公不愿意和我亲近怎么办?

老公不愿意和你亲近你有两种办法,一种你想办法让自己变成你老公喜欢的样子,另一种你亲近别人刺激一下你老公的心理,如果还不见效,那基本上没戏了,离婚即可。一、为什么不愿意亲近你知己知彼,方可获胜,你首先得弄清楚你老公为什么不愿意亲近你,例如传染病、其他疾病、身体太累、不喜欢你、卫生洁...

你看过最性感的电影是什么?

有最恐怖的,最唯美的,最劲爆的,有最性感的电影吗?...

龙岩哪个县城发展最快?

感谢您的邀请,作为上杭人,必须来回答这个问题,讲三点。1.龙岩哪个县城发展最快,当然是上杭县。上杭的年内生产总值在各个县排名第一。上杭的经济也是飞速的发展,生活水平也是不断地提高。上杭房价12000一平,你们县城有吗?2.上杭的城市建设在不断的完善中。创建全国文明城市、创建全国森...

三亚景点哪个最好玩?

想吃海鲜的话哪里不会被宰?...

交了社保到60周岁,刚领一个月工资就死了怎么办?

感谢邀请!这个问题关系到千家万户 ,关系到我们每一个人。所以,我就社保从开始缴纳到领取以及没领够时间就死亡了怎么办的问题,把我所了解和掌握的相关政策,分享给大家。城乡居民养老保险其实是两部分,一部分是自己缴纳的,一部分是政府补贴的。比如,你每年缴纳200元,政府就为你补贴35元(...

猜你喜欢
热门推荐
秒速时时彩